目录

今天准备在服务器上构建一个前端项目,我的服务器用的 Linux 是 CentOS 7,我通过 Yum 安装了 Nodejs。在运行构建命令的时候出现了一堆错误信息,项目也无法成功构建,其中的一段错误信息如下:

npm ERR! Make sure you have the latest version of node.js and npm installed.

我使用 node -v 查看了一下 Nodejs 的版本,发现 Yum 安装的 Nodejs 竟然是 6.x 的版本。最新的 Nodejs 版本已经到了 14.x,Yum 上的还是 6.x 的版本,也就是说 Yum 上的 Nodejs 至少是两年前的版本。

我只能到 Nodejs 官网下载最新的 Nodejs 安装,这里简单记录一下安装过程。

下载

直接进入 https://nodejs.org/zh-cn/download/current/,选择 Linux 二进制文件 (x64),如下:

Nodejs下载

复制下载地址,可以通过 wget 或 curl 下载。

我这里把 Nodejs 下载到 /opt 目录,进入 /opt 目录:

cd /opt

使用 wget 下载 Nodejs:

wget https://nodejs.org/dist/v14.4.0/node-v14.4.0-linux-x64.tar.xz

下载的 Nodejs 是一个 tar.xz 的压缩包。

解压:

tar xf node-v14.4.0-linux-x64.tar.xz

解压后得到一个 node-v14.4.0-linux-x64 目录,node-v14.4.0-linux-x64 中又有一个 bin 目录,环境变量的路劲就需要配置到 bin 目录。

配置环境变量

用 VI 之类的编辑器打开 /etc/profile,加入:

export PATH=$PATH:/opt/node-v14.4.0-linux-x64/bin

保存退出后输入:

source /etc/profile

让设置生效。

查看一下 Nodejs 版本:

node -v
v14.4.0

查看一下 npm 版本:

npm -v
6.14.5

相关文章:

版权声明:本文为原创文章,版权归 Mr. Ma's Blog 所有,转载请联系博主获得授权!
本文地址:https://www.misterma.com/archives/878/
如果您对本文有什么问题或疑问都可以在评论区留言,我看到后会尽量解答。
最后编辑:2020年06月22日 ©著作权归作者所有

发表评论

正在加载 Emoji